Changes to building QGIS 1.9 on Arch

Recently Arch added QT5 to their repositories and renamed the old QT package to QT4.  This causes a little confusion for the qgis-git PKGBUILD since it lists the old qt package as a dependency.  It’s an easy fix, just change qt to qt4 and add

-DQMAKE_EXECUTABLE=/usr/bin/qmake-qt4

to the ./configure options.

Once 1.9 is compiled and built you can see how far along this beta version has come.  The new loader built into the DB Manager plugin works flawlessly.  This is my favorite new feature in 1.9 / 2.0.  It makes it so if you can add a dataset to a QGIS map, it only takes a few clicks to import that data into a new PostGIS layer.  It really comes in handy with layers created by ad-hoc queries.

Plugin developers have been hard at work adjusting their plugins to work with the new API.  OpenLayers has been updated, just upgrade through the Fetch Python Plugins menu and you can once again display your Google, Bing, etc maps in QGIS.

 

Advertisements
    • pvanb
    • April 28th, 2013

    Thanks, that did solved one error when compiling QGIS on Ubuntu 13.04.

  1. April 28th, 2013

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: